Sales
0161 215 3700
0800 458 4545
Support
0800 230 0032
0161 215 3711

Mozilla to Force Firefox Update

Mozilla to Force Firefox Update

Mozilla plans to push 12 million users of the aged Firefox 3.5 to a newer version next month by taking the unprecedented step of automatically upgrading their browser.

Firefox 3.5, which debuted in mid-2009, is already on life support. Mozilla gave users their last version 3.5 security patches three weeks ago. But in June, Mozilla will use another strategy to make Firefox 3.5 "being dead," as one page on the company's site said.

While it will continue to "dangle the carrot" of Firefox 4 to those users, Mozilla started offering an upgrade to Firefox 4 to people running Firefox 3.5 and Firefox 3.6 last week, it will "force 3.6 on 3.5 stragglers not choosing to update to Firefox 4 or 3.6 (give them the stick)," wrote Christian Legnitto, the Firefox release manager, in a message posted to a developer mailing list.

Later, Legnitto said his choice of the word "force" was ill advised, and noted that only Firefox 3.5 users who had left the default automatic updates setting enabled would be moved to Firefox 3.6 automatically.

That step is a first for Mozilla, as Legnitto acknowledged in an explanation.

"We are treating the automatic update checkbox enabled as a 'Yes, I want Mozilla to keep me updated,'" Legnitto wrote. "Previously as a courtesy we had people opt-in between major versions due to the potential jarring nature of the update. We feel the difference between 3.5 and 3.6 is not severe, and with 3.5 reaching end-of-life, 3.6 is the security update for 3.5 users."

Mozilla would prefer that the estimated 12 million Firefox 3.5 users upgrade to the much newer Firefox 4 instead, but will settle for migrating them to Firefox 3.6 , the version that launched in January 2010.

On June 21, the day Firefox 5 is supposed to ship, Mozilla will automatically push Firefox 3.6.18 a standard security update, if the company resolves a few remaining bugs. If those bugs don't get fixed by then, the auto-update will hit Firefox 3.5 users some time later.

Before that, however, Mozilla will rev up the warnings to Firefox 3.5 users that they're running a now-unsupported browser .

Mozilla has already told Firefox 3.5 users that they're running an out-of-date browser.

Firefox 3.5 users can avoid the message and June's auto-update by downloading and installing Firefox 4.0.1 , which runs on Windows, Mac OS X and Linux.


print this article

Return to linux news headlines
View Linux News Archive

Share with: