Alexa metrics
Live Chat

Welcome to UKFast, do you have a question? Our hosting experts have the answers.

Chat Now
Sarah UKFast | Account Manager

The New Heartbleed?

9 June 2014 by Jenn Granger

Six bugs have been found wriggling around inside OpenSSL, and it’s time to call in the exterminators. OK, melodramatic analogies aside, it’s been said that it’s about a seven on the one to Heartbleed scale; which means it’s not time to freak out and trash your computer, but you do need to check your software is up to date – and keep it that way. Want to know more? Lemme break it down for you:


What is OpenSSL?

It’s a free internet software package that encrypts our info to keep it safe on its journey round the internet (in theory, at least). Users include big names in tech like Google, Facebook, Yahoo and Amazon.

Is it another Heartbleed situation?

Yeeeahkinda – but not as bad. After Heartbleed, people started realising that it might be a grand idea to put some time, energy and money into plugging any holes to stop it happening again; it turns out that was a good shout, because last week they discovered the OpenSSL bugs. Computer-science professor Matthew D Green has likened it to spring cleaning, and said it’s a good thing they’ve been found. On the flipside, one response was that it’s more like finding a nest of venomous spiders in your house, so it’s all a matter of perspective really!

According to Masashi Kikuchi, the Japanese security researcher who found the flaw, the CVE-2014-0224 MITM bug has probably been around since the very first release of OpenSSL…nearly sixteen years ago. Oops.

Anyway, general consensus is that it’s not quite as bad as Heartbleed, and the holes are harder to exploit, but that you should still check to see if you’re affected and upgrade pronto.

The tech bit

Holes include a DTLS invalid fragment bug that’s been around since April but was only reported last Thursday (CVE-2014-0195, affects versions 0.9.8, 1.0.0 and 1.0.1), which can be used to inject malicious code into vulnerable software in apps, devices and servers; and man-in-the-middle (MITM) bugs which spy on encrypted connections. The OpenSSL guys explain the SSL/TLS MITM vulnerability (CVE-2014-0224, potentially affects all clients, and servers running 1.0.1 and 1.0.2-beta1):

“An attacker using a carefully crafted handshake can force the use of weak keying material in OpenSSL SSL/TLS clients and servers. This can be exploited by a man-in-the-middle (MITM) attack where the attacker can decrypt and modify traffic from the attacked client and server.”

It’s not all bad news on that last one though: “The attack can only be performed between a vulnerable client *and* server. OpenSSL clients are vulnerable in all versions of OpenSSL. Servers are only known to be vulnerable in OpenSSL 1.0.1 and 1.0.2-beta1. Users of OpenSSL servers earlier than 1.0.1 are advised to upgrade as a precaution.”

So: If you’re a client of OpenSSL you need to upgrade. If you have a server in OpenSSL 1.0.1 and 1.0.2-beta1 you need to upgrade. And if you use an OpenSSL server earlier than 1.0.1 then why not just upgrade anyway, because it’s what all the cool kids are doing.

What’s happening now?

Nicholas J. Percoco, veep of strategic services at vulnerability management firm Rapid7, explained that because of the rush to upgrade OpenSSL post-Heartbleed, most devices using the software will have the most recent version. Which is actually vulnerable. Ironically.

He said: “A man-in-the-middle attack is dangerous because it can allow an attacker to intercept data that was presumed encrypted between a client – for example, an end user – and a server – eg, an online bank. This attack is also passive in nature and will may not be detected by the client, server or network-based security controls.” So, just because you can’t see it, doesn’t necessarily mean it’s not there.

Also, you might’ve heard the term ‘LibreSSL’ kicking about. This is a fork of OpenSSL (where developers copy a programme and then start working on it independently, splitting it off completely from the original software) created by the same guys in charge of OpenBSD. They created Libre after criticising OpenSSL as not security-conscious enough. However – more good news – LibreSSL is probably also vulnerable.

What do I need to do?

The OpenSSL team has brought out fixes for the vulnerabilities, so it’s time to start kicking the bugs out of your system.

Chester Wisniewski, writing on the blog of security firm Sophos said: “Patch early and patch often… You will likely see updates for many of your programs on your computer and Android smartphones being updated over the next few weeks.”

Adam Langley, a senior software engineer at Google, has further advice on his blog: “The good news is that attacks [exploiting CVE-2014-0224] need a man-in-the-middle position against the victim, and that non-OpenSSL clients (Internet Explorer, Firefox, Chrome on Desktop and iOS, Safari etc) aren’t affected.” He still recommends all OpenSSL users should be updating though.

What should I upgrade to?

Users of OpenSSL servers earlier than 1.0.1 are advised to upgrade as a precaution.

OpenSSL 0.9.8 SSL/TLS users (client and/or server) should upgrade to 0.9.8za.

OpenSSL 1.0.0 SSL/TLS users (client and/or server) should upgrade to 1.0.0m.

OpenSSL 1.0.1 SSL/TLS users (client and/or server) should upgrade to 1.0.1h.

If you’re at all worried about the security of your solution, give us a call on 0208 045 4945 or contact your account manager.